Inicial > Tecnologia > Comandos e Configurações CISCO (Incluindo configuração de vlan)

Comandos e Configurações CISCO (Incluindo configuração de vlan)

Salve galera!!

Recentemente precisei criar vlans em um Switch Cisco e encontrei certa dificuldade para encontrar um material para “iniciante”, pois a maioria dos tutorias/dicas somente abordam o resultado e os comandos finais e nem sempre mostram o caminho ate chegar neles. Então resolvi montar um “frankenstein”, pegando um conhecimento daqui, um tutorial ali, uma dica acula e voilá…

Abaixo seguem algumas dicas legais:

1- Entrar no modo privilegiado:

switch>enable

Password:*******

switch#

 

2- Configurar ou alterar a senha do modo privilegiado:

switch# config t

switch(config)#enable secret ****** digite a senha

switch(config)#exit

 

3- Configurar um nome para o Switch:

switch#configure terminal

switch(config)#hostname NOME

switch(config)#exit

switch#

 

4- Configurar velocidade e modo de comunicação da porta:

Switch 2950:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)#speed 100

switch(config-if)#duplex full

 

5- Configurar o endereço IP/Máscara/Gateway nos Switches:

switch#configure terminal

switch(config)#interface vlan 1

switch(config-if)#ip address X.X.X.X Y.Y.Y.Y onde X é o endereço IP e Y a máscara de rede

switch(config-if)#exit

switch(config)#ip default-gateway X.X.X.X onde  X é o endereço IP do default-gateway

switch(config)#exit

switch#

 

6- Criar VLANs nos Switches:

switch#config t

switch(config)#vlan 2

switch(config-vlan)#name NAME

switch(config-vlan)#exit

switch(config)#exit

switch#

 

7- Atribuir portas as VLANs:

Portas 3, 4 e 5 –> VLAN 2

switch#config t

switch(config)#interface fastEthernet 0/3

switch(config-if)#switchport access vlan 2

switch(config-if)#exit

switch(config)#interface fastEthernet 0/4

switch(config-if)#switchport access vlan 2

switch(config-if)#exit

switch(config)#interface fastEthernet 0/5

switch(config-if)#switchport access vlan 2

switch(config-if)#exit

switch(config)#exit

switch#

switch#show vlan  (visualiza VLAN)

 

8- Configurar TRUNK:

Switch 2950:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)#speed 100

switch(config-if)#duplex full

switch(config-if)#switchport mode trunk

switch(config-if)#exit

switch(config)#exit

switch#show run

——————————————————–

Switch 2900:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)#speed 100

switch(config-if)#duplex full

switch(config-if)#switchport mode trunk

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)#exit

 

9- Configurar Espelhamento de portas para coleta de dados:

Exemplo Espelhar as portas 1, 2 e 3 para porta 24.

Switch 2950:

switch#config t

switch(config)#monitor session 1 destination interface fastEthernet 0/24

switch(config)#monitor session 1 source interface fastEthernet 0/1

switch(config)#monitor session 1 source interface fastEthernet 0/2

switch(config)#monitor session 1 source interface fastEthernet 0/3

switch(config)#exit

OU

switch#config t

switch(config)# interface fastEthernet 0/24

switch(config-if)#port monitor FastEthernet 0/1

switch(config-if)#port monitor FastEthernet 0/2

switch(config-if)#port monitor FastEthernet 0/3

switch(config-if)#exit

switch(config)#exit

 

10- Salvar arquivo de configuração:

switch# copy running-config startup-config ou write

 

11- Configurar relógio do switch:

switch# clock set 12:06:00 30 may 2005

 

12– Configurar modo de exibição do log:

switch#config t

switch(config)# service timestamps log datetime

 

13– Configurar tamanho do log:

switch#config t

Switch(config)# logging buffered 8192

 

14– Configurar servidor de log:

switch#config t

Switch(config)# logging X.X.X.X onde  X é o endereço IP do servidor de Logs

 

15– Criptografar as senhas console e telnet (configure terminal):

switch#config t

Switch(config)#service password-encryption   (habilita a criptografia)

 

16– Configurar Lista de acesso (MAC):

switch#config t

switch(config)#mac access-list extended TESTE

Switch(config-ext-macl)#permit host XXXX.XXXX.XXXX host YYYY.YYYY.YYYY    onde  X e Y são os endereços MAC

switch#conf t

switch(config)#int fas 0/5

switch(config-if)# mac access-group TESTE in   (atribuir lista a interfece)

 

17– Configurar controle de storm de broadcasts:

Switch 2950:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)#storm-control broadcast level N   //N= % da banda a ser limitada//

switch(config-if)# storm-control action shutdown  //Caso atinja o limite acima  porta ficará em shutdown//

switch(config-if)#exit

Switch 2900:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)# port storm-control broadcast threshold rising X falling Y   //Onde rising X  é o limite superior em pacotes/seg e falling Y é o limite inferior para a porta retornar ao estado up//

switch(config-if)# port storm-control broadcast action shutdown //Caso atinja o limite acima  porta ficará shutdown//

switch(config-if)#exit

 

18– Desabilitar Trunk automático no 2950:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)#switchport mode access

 

19 – Recuperar senha do switch:

a- Fazer a conexão com o switch através da porta console (9600 bps).

b- Desconectar o cabo de alimentação do switch.

c- Pressionar o botão Mode e mantê-lo pressionado enquanto reconecta o cabo de alimentação do switch. Mantenha o botão Mode pressionado dois segundos após o led da porta 1X apagar.

d- Aparecerão as seguintes mensagens:

The system has been interrupted prior to initializing the flash file system. The following commands will initialize the flash file system, and finish loading the operating system software:

flash_init

load_helper

boot

e- Inicializar o arquivo Flash do sistema:

switch: flash_init

f- Carregar arquivos de ajuda:

switch: load_helper

g- Visualizar o conteúdo da memória Flash:

switch: dir flash:

Note que o arquivo config.text é o arquivo de configuração que contém as definições sobre a senha.

h- Renomear o arquivo de configuração para config.text.old

switch: rename flash:config.text flash:config.text.old

i- “Bootar” o switch

switch: boot

j- Após a inicialização do switch, aparecerá a seguinte pregunta: Deseja entra no modo de configuração “diálogo”?

Digite: no

l- No prompt de comando entre no modo privilegiad

switch> enable

m- Renomear o arquivo de configuração para o seu nome original (config.text)

switch: rename flash:config.text.old flash:config.text

n- Copiar o arquivo de configuração para a memória:

Agora a senha já pode ser alterada.

o- Entrar no modo de configuração global:

switch# config terminal

p- Alterar a senha:

switch(config)# enable secret *********

q- Retornar ao modo privilegiado e gravar as novas configurações:

Switch(config)# exit

Switch# write

Após estes procedimentos a nova senha já estará incluída no arquivo de configuração inicial.

Tambem anexei um tutorial para iniciantes: Primeiros Passos Cisco

Ate a proxima PessoAll… 🙂

Anúncios
Categorias:Tecnologia
  1. Ricardo
    agosto 17, 2012 às 5:17 pm

    Ae! Valeu!! Da Hora!! Nem lembrava mais !!

  2. abril 24, 2013 às 6:00 pm

    Pretty nice post. I just stumbled upon your blog and wanted to say that I’ve truly enjoyed surfing around your blog posts. After all I’ll be subscribing for your
    rss feed and I hope you write again very soon!

  3. junho 21, 2013 às 7:38 am

    I do not even know how I ended up here, but I thought this post was good.
    I do not know who you are but certainly you are going to a famous blogger if you are not already 😉 Cheers!

  4. lain
    novembro 29, 2013 às 7:13 pm

    Eu te amo cara…Demais eu até namoraria com você…sério…

  5. maio 27, 2014 às 4:51 pm

    Republicou isso em Cisco Plus+.

  6. Roberto Sousa
    julho 2, 2015 às 6:12 pm

    Olá… sabe como faço para configurar duas portas com o mesmo IP?
    Tenho um router CISCO com cinco portas WAN e uso atualmente apenas uma das portas para conexão com o roteador do meu provedor de link de internet.
    Preciso adicionar mais uma porta de saída pois o tráfego já está no limite da porta atual.
    Portanto, preciso fazer com que o tráfego seja encaminhado pelas duas portas.
    Coo posso fazer? As duas portas ficarão com o mesmo IP? Será algum tipo de agregação de portas? Quais seriam as soluções?

  7. junho 26, 2016 às 9:21 pm

    Post antigo, mas me ajudou muito. PARABENS AMIGO!!!!
    Obrigado!

  8. Julio
    setembro 2, 2016 às 1:13 am

    Belo poste chefe .. Deixa eu tirar uma dúvida com você … Como eu faço para saber se o router da cisco suporta Vlan na porta wam (ppoe- vlan 10) ou como chama essa função no router ?
    Ou todos router fazem isso ?
    Obrigado
    Vlw

  9. outubro 8, 2018 às 10:29 pm

    It’s difficult tto find experienced people for this subject, but you seem like
    yoou know what you’re talking about! Thanks

  1. No trackbacks yet.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

%d blogueiros gostam disto: